FAQs on Migration of Connect from Google to Microsoft

Useful Pages on Migration of HKU Connect Accounts from Google to Microsoft

  1. Activate your Microsoft account here, go to https://portal.office.com and click Sign in.
  2. Select Work or school account.
  3. Enter yourUID@connect.hku.hk and your graduate email account password.
  4. You can start using the OneDrive.

Email  

Access via 

 

  1. MyEmail tab of HKU Portal or 
  2. https://mail.office365.com using yourUID@connect.hku.hk and PIN  

 

Steps for email migration (deadline: by 31 May 2023): to be provided later 

Storage  

Access via https://portal.office.com > select Work or school account > enter yourUID@connect.hku.hk and PIN > Use OneDrive and other O365 apps


Storage size of OneDrive under each account: 5TB


Steps for file migration (deadline: by 31 May 2023):
here 

File sharing 

The previous file sharing you set up on Google Drive will continue to work until 31 May 2023 or before the files are transferred or removed, whichever is earlier.  After the files are relocated, please set up the filing sharing on OneDrive or other storage devices again if necessary.   

 

Steps for filing sharing (deadline: by 31 May 2023): here 

Google authentication  You can keep using your Google account for authentication purpose after May 2023 if your Google storage is emptied.  This can be done by doing a simple registration and the registration steps will be provided later.  

Switch over of HKU Connect account from Google to Microsoft (i.e., the email will be delivered to Microsoft)

June 1, 2022

Google account remains accessible for data transfer

(read-only access)

until May 31, 2023

Registration for keeping a Google account for authentication purposes

before May 31, 2023

Deletion of Google account (if not kept for authentication)

June 1, 2023

You can still login to the Google platform via webmail.hku.hk (please select connect.hku.hk – Gmail account) to continue transferring your data until 31 May 2023.  Please however note that the Google accounts from 1 June 2022 onwards will be changed to a “read-only” mode, i.e., the account will have no email sending, email receiving, file sharing and file upload functions. The Google account will be deleted after 31 May 2023 unless you register to keep it for authentication purpose with an empty storage.   

If you wish to keep your Google accounts for authentication purpose after 31 May 2023, you can register to keep it if your Google drive storage is emptied (storage size = 0).  Registration steps will be provided later.

Yes, users have to migrate the emails and data under the Google account themselves if they wish to keep a copy of them.

  1. All new emails sent to your uid/alias@connect.hku.hk will be delivered to the inbox of your Microsoft account instead of Gmail.
  2. Google Drive will be changed to read-only mode. You can continue accessing and migrating your files but you cannot add new files.
  3. Google Drive sharing function will be disabled. You can migrate your data to OneDrive or other storages and set up the sharing again.
  4. Google Drive related tools, such as Google Drive for desktop and Google Drive Backup and Sync, will be disabled.
  5. Google Photos will be disabled. You can download using Google takeout if you wish to keep a copy.
  1. Still can use Sign in with Google for third-party services, e.g. Spotify, Evernote, Dropbox, etc.
  2. Migrate/download files from Google Drive (cannot add new files).
  3. You can continue using other services provided by Google except for Gmail, Drive, and Photos.

    * ITS will stop providing support for the services on the Google Connect account after the migration date. 
  1. Start migrating your emails from Gmail to Microsoft platform. Migration steps are available at here.
  2. Continue migrating your files on Google Drive and Google Photos to Microsoft OneDrive or other storage devices. Detail could be found at here.
  3. If you wish to keep your Google accounts for authentication purpose after 31 May 2023, you can register for this as long as your Google drive storage is emptied (storage size = 0). Please click here for the registration.

Graduates can start using your OneDrive (with 5TB storage) now AFTER you reset your graduate email account password once if you have not accessed your OneDrive before.  

Follow the steps above to login to OneDrive to activate its use.  You can click here for the steps to transfer data from Google Drive to OneDrive using Mover. 

 

After the data transfer is completed, please delete all files from your HKU Connect Google Drive.  

From our testing, it may take 4 days to transfer 1TB data and 7 days to transfer 2TB data using Mover.  After you initiate the data transfer on Mover, you can close the browser and turn off your PC.  To check the data transfer progress, you can go to https://www.mover.io/ and select Migration Manager.  You will receive a completion email after the data transfer is completed.  

Update on 27 May 2022:

The recommended solution, Mover, for migrating data on Google Drive to Microsoft OneDrive is temporarily unavailable for use due to a server error.  ITS is checking with Mover and Microsoft to look into the cause of the problem and see how it can be resolved. 

The migration procedure of using Mover will be posted up again when the Mover service is resumed.  All HKU Connect users will have 12 months to complete the data migration and they can continue accessing their HKU Google accounts (read-only mode) until 31 May 2023.

Please arrange the data migration later if you would like to use Mover to do it. 

Alternatively, you can consider downloading the files to your PC before you upload them to OneDrive or other storage devices.  Please also click here for other means on data transfer. 

Please migrate all data from Google Drive and Google Photos and DELETE all files from your HKU Connect Google Drive.  

 

Review current Google storage https://drive.google.com/settings/storage 
Manage files in Google storage 

https://support.google.com/drive/answer/6374270?hl=en 

 

Reduce Google storage  
  1. Disable Google Backup and Sync 
  2. Reduce Google Drive Storage 
  3. Reduce Google Photos Storage 
  4. Reduce Gmail Storage 

Transfer Data  

-Export and download data from the Google products 

– Google Drive 

– Google Calendar 

– Google Contacts 

– Google Photos 

– Transfer to another personal Gmail account 

https://its.hku.hk/kb/ways-on-reducing-storage-on-google-drive-google-photos-and-gmail/#transfer-data 

 

 

error on transfering content

If you see error: “Transfer Your Content is only available to authorised G Suite for Education Accounts. Please contact your administrator”, this may due to you used the same web browser to login both Connect and personal Gmail accounts.
Please try to logout all accounts. Use 2 different web browsers, (may be Chrome and Firefox), to login Connect and Gmail separately and try again.

  1. “BrowserAuthError: hash_empty_error”

     

    Please retry by using a web browser in private mode and go to https://mover.io.

     

    Chrome (Incognito mode) https://support.google.com/chrome/answer/95464
    Firefox (Private Browsing) https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history
    Safari (Private Browsing) https://support.apple.com/en-hk/guide/safari/ibrw1069/mac
    Microsoft Edge (InPrivate) https://support.microsoft.com/en-us/microsoft-edge/browse-inprivate-in-microsoft-edge-cd2c9a48-0bc4-b98e-5e46-ac40c84e27e2

     

  2. Migration completed with errors

     

    1. If you have already started a migration task, login to https://mover.io >  Migration Manager > select the latest task > Re-run 1 Transfer.

       

      The following file types are not supported by Mover.io (Microsoft website refers).  Please skip these files or migrate them manually (e.g. download to local PC from Google Drive and upload to OneDrive manually).

       

      • Files with a size of 0 bytes (zero-byte files)
      • Files larger than 15GB
      • Shortcut files
      • Suspicious/Virus files
      • Folder/File names with special characters
      • Folder/File names too long

       

    2. You may check the migration log to review the reason of failure.Login https://mover.io >  Migration Manager > select the latest task > Click the ⓘ icon > Transfer Logs > Log button > Failures button

       

      Please check the Failure logs.  Logs with “Skipping because of incremental.” are fine as re-run task will skip these files that have already been migrated.

       

      click the icon

       

      click transfer log

       

      click failure

       

      Example of failure reasons:

       

      check the result

After HKU Connect accounts are migrated from Google to Microsoft on 1 June 2022, all Google accounts are accessible in read-only mode to allow users to continue transferring their files and data.  From 1 June 2022 onwards, all Google accounts are set with a quota limit of 100MB and alert will be shown when the storage size exceeds this limit. You can continue accessing your account in read-only mode until 31 May 2023 though you can’t save/share new files or receive new emails under your Google account.

 

Google Storage

google storage interface 

Google Drive

google drive interface

Google Photos 

google photos interface

Please go to https://webmail.hku.hk and click the button “CONNECT.HKU.HK (Google, read-only).

webmail button of connect.hku.hk with google

Transfer of file/folder ownership between HKU Connect Google Drive and personal Google Drive is not supported.

You can either:

  1. Download the files and upload to your personal account, or
  2. Use Google Transfer to transfer your files in Google Drive to your personal Google Drive

https://its.hku.hk/kb/ways-on-reducing-storage-on-google-drive-google-photos-and-gmail/#migrate-mails-and-files-to-personal-gmail-account-with-google-transfer

Files/folders shared by others will not be migrated by Mover.io, Google Takeout or Google Transfer.

You can either:

  1. Download the files and upload to your M365 OneDrive or personal Google Drive, or
  2. Request the file/folder owner to share the files/folder again to your personal Google account.

The items in “My Computer” should have been backed up on your computer and/or synchronized with Google backup and sync app.

Please install the Microsoft OneDrive client on your computer and select the folders you want to sync with OneDrive.

https://www.microsoft.com/zh-hk/microsoft-365/onedrive/download

Please also disable the Google backup and sync on your computer.

https://its.hku.hk/kb/ways-on-reducing-storage-on-google-drive-google-photos-and-gmail/#a-disable-google-backup-and-sync

The Outlook Import/Export function on Mac is grey out like this:

The Outlook Import/Export function on Mac is grey out


It is a problem of the new Outlook interface. Please change “New Outlook” to “Legacy Outlook” using the following steps:

  1. Under Menu > Outlook > deselect New Outlook. Click Revert to confirm this change.

    Under Menu > Outlook > deselect New Outlook. Click Revert to confirm this change

  2. Click Revert to confirm this change.

    Click Revert to confirm this change

  3. Restart your Mac and the interface will be changed to Legacy Outlook and the Import and Export options will be available.

    Restart your Mac and the interface will be changed to Legacy Outlook and the Import and Export options will be available

    Restart your Mac and the interface will be changed to Legacy Outlook and the Import and Export options will be available

Symptom:

Import/Export button grey out in MS Outlook Desktop Application on Windows.

Import/Export button grey out in MS Outlook Desktop Application on Windows

Cause:

The Microsoft 365 (office) language does not match with the Windows non-Unicode locale

 

Solution:

Go to Control Panel -> Uninstall a program

Go to Control Panel -> Uninstall a program

Check the language of the installed Microsoft 365 (Office) app and close the Window. Don’t uninstall anything.

Check the language of the installed Microsoft 365 (Office) app and close the Window. Don’t uninstall anything.

Go to Control Panel -> Change data, time, or number formats

Go to Control Panel -> Change data, time, or number formats

Go to Administration tab> Language for non-Unicode programs

If the language not match with the Microsoft 365 app language, click Change System locale to change.

Go to Administration tab> Language for non-Unicode programs

Change to the language to match with the language of Microsoft 365 app.

Change to the language to match with the language of Microsoft 365 app

You may need to restart the computer after change this setting.

Please run the following script which could help to convert the imported mail folder(s) to Outlook native format.
  1. Open the MS Outlook 365 Client
  2. Download script file here (filename: fiximportedimapfolders.zip)Download script file here (filename: fiximportedimapfolders.zip)
  3. Extract the zip file. Open the extracted folder and double click the FixImportedIMAPFolders.vbs fileExtract the zip file. Open the extracted folder and double click the FixImportedIMAPFolders.vbs file
  4. Click OK to run the fileClick OK to run the file
  5. Select the Outlook icon on task barSelect the Outlook icon on task bar
  6. You will see the follow windows. Select the Import from Gmail folder and click OK.You will see the follow windows. Select the Import from Gmail folder and click OK.
  7. Select the following icon on Task barSelect the following icon on Task bar
  8. Click Yes, to include subfoldersClick Yes, to include subfolders
  9. Click OK to completeClick OK to complete
  10. The imported mails will show up on mobile Outlook/Mail app.
  Credit: Solution was provided by howto-outlook.com .
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